Herramientas Personales
Usted está aquí: Inicio ¡Participa! Foros
Acciones de Documento
Hilo cerrado

Solicito ayuda para sonido y teléfono

Volver al foro (Desarrollo de Guadalinex Mini V3)
Orden:   
  • Escrito por soberon el 21/04/2006 20:48

    soberon

    Adepto Ancestral

    Envíos: 299

    Saludos a todos los amables foristas...
    Tengo un par de cuestiones para los notables expertos que ya me han auxiliado en ocasiones anteriores:
    En mi vieja portátil Toshiba Satellite 220 CDS de 80 Mb RAM y solo 1.4 Gb en disco duro tengo instalado GuadaMini. Todo opera de maravilla EXCEPTO
    a) el sonido... ¿cómo averiguo que tarjeta de sonido tiene este equipo?, y -suponiendo que lo encuentre- ¿que hago para configurarla y que funcione?
    b) la tarjeta de fax-modem PCMCIA marca ActionTec modelo DataLink de 33.6 Kbps (V.34+)... ¿cómo la instalo o hago que la reconozca y cómo la configuro para acceso telefónico a internet?
    Se que son preguntas muy elementales, pero reconozco mi extrema novatez.
    Ojalá tengan el tiempo de orientarme y de antemano MIL GRACIAS :-D :hammer:

    p.d. Por cierto, también tiene una PCMCIA de red 3com que fué reconocida y activada sin ninguna intervención mía. Es a través de la que estoy escribiendo.
    ...
    • Re: Solicito ayuda para sonido y teléfono

      Escrito por ailime el 25/04/2006 12:33

      ailime

      Iniciado Ancestral

      Envíos: 80

      Si ejecutas el comando lspci,en un terminal, te muestra los dispositivos q posee tu ordenador. una vez vista q tarjeta tiene busca los drivers y mira si son compatinles con linux y si es asi instala los drivers y debe funcionar el sonido.
      ;-)
      • Re: Solicito ayuda para sonido y teléfono

        Escrito por soberon el 27/04/2006 07:11

        soberon

        Adepto Ancestral

        Envíos: 299

        Gracias Ailime... lo haré; sin embargo no tengo idea de que hacer con la información que me rinda lo del "Ispci". Voy a "pegar" la información en este mismo hilo y -si tus ocupaciones lo permiten- te agradeceré muchísimo tu orientación.
        Saludos :-D
        ...
        • Re: Solicito ayuda para sonido y teléfono

          Escrito por basoalto el 27/04/2006 09:01

          basoalto

          Maestro Ancestral

          Envíos: 1934


          lo del "Ispci".



          soberon ten cuidado con lo que has escrito. El comando lspci que te han comentado empieza por L de Lugo y no por I latina.

          Saludos.
          Kernel Source Blog sobre Software Libre Desde mi azotea - Mi blog de astronomía ............
          • Re: Solicito ayuda para sonido y teléfono

            Escrito por soberon el 28/04/2006 05:45

            soberon

            Adepto Ancestral

            Envíos: 299

            Gracias Basoalto... efectivamente no lo había entendido.
            ...
            • Re: Solicito ayuda para sonido y teléfono

              Escrito por basoalto el 28/04/2006 10:12

              basoalto

              Maestro Ancestral

              Envíos: 1934

              soberon puede ser que la tarjeta de sonido esté deshabilitada desde la BIOS del ordenador. ¿Has comprobado esto?

              saludos
              Kernel Source Blog sobre Software Libre Desde mi azotea - Mi blog de astronomía ............
              • Re: Solicito ayuda para sonido y teléfono

                Escrito por soberon el 29/04/2006 00:16

                soberon

                Adepto Ancestral

                Envíos: 299

                Gracias Basoalto...
                Ya revisé la BIOS y esto es lo que encontré (este "chorizo" de datos no me dicen mucho, pero tal vez a ustedes si):

                PC Card Controller Mode=PCIC Compatible

                Sound=Enabled (y despliega)-->
                WSS I/O Adress=530H
                SBPro I/O Adress=220H
                Synthesizer I/O Adress=300H
                WSS&SBPro&MPU401 IRQ Level=IRQ5
                WSS(Play) DMA=Channel 1
                WSS(Rec)&SBPro DMA=Channel 0
                Control I/O Adress=370H
                MPU401 (MIDI I/F)=330H

                PCI Bus=IRQ11

                ¿Hay algo útil en esto?...
                Agradezco su apoyo :lol:
                ...
                • Re: Solicito ayuda para sonido y teléfono

                  Escrito por basoalto el 29/04/2006 12:32

                  basoalto

                  Maestro Ancestral

                  Envíos: 1934

                  Unas dudas que me surgen soberon. En la opción:


                  PC Card Controller Mode=PCIC Compatible



                  ¿Tienes otros modos disponibles? Además del PCIC Compatible.

                  Y cuando en la BIOS tienes seleccionada la opción:


                  Sound=Enabled



                  Si escribes lspci desde el sistema, no te aparece ninguna información relativa a la tarjeta de sonido?

                  Saludos.
                  Kernel Source Blog sobre Software Libre Desde mi azotea - Mi blog de astronomía ............
                  • Re: Solicito ayuda para sonido y teléfono

                    Escrito por soberon el 29/04/2006 16:52

                    soberon

                    Adepto Ancestral

                    Envíos: 299

                    Hola Basoalto...
                    Efectivamente, parece que la cosa va por ahi. Siguiendo tus acertados consejos (¡increible!... a distancia y sin conocer el equipo ¡eso es conocimiento!) revisé de nuevo la BIOS:
                    En PCI Card Controller Mode además de PCIC Compatible existe la opción "CardBus/16-bit". Ya la activé y ahora con el comando lspci aparecen dos lineas nuevas (además de Host, VGA y USB que siguen iguales)
                    0000:00:02.0 CardBus bridge: Toshiba America Info Systems ToPIC95 (rev 07)
                    0000:00:02.1 CardBus bridge: Toshiba America Info Systems ToPIC95 (rev 07)
                    Dicen lo mismo excepto el final de la serie numérica inicial.
                    Pero sigue sin mencionarse nada referente a sonido. Tampoco se abre el AUMIX.
                    En windows (el SO original en mi compu), lo referente a sonido dice Yamaha OPL3-SAxWDM y aparentemente todo eso viene en un CD -que conservo- que vino con el equipo y dice Toshiba Utilities and Drivers... tal vez (solo especulo) podría sacarse de aquí vía ndiswrapper o algo asi ¿no?. Me encantará saber tu opinión.
                    Gracias de nuevo :lol:
                    ...
                    • Re: Solicito ayuda para sonido y teléfono

                      Escrito por basoalto el 30/04/2006 01:02

                      basoalto

                      Maestro Ancestral

                      Envíos: 1934

                      Vamos a ver compañero, parece que la BIOS de tu máquina es un poco peculiar, pero tranqui que con paciencia e Internet todo se saca hacia adelante.
                      Se me ocurre que ejecutes la utilidad alsaconf, a ver si te detecta alguna tarjeta de sonido.
                      El ndiswrapper sólo sirve para los adaptadores wireless.
                      Por cierto, qué modelo es tu portátil. Es para echar un vistazo por internet a ver si encuentro algo de información.

                      Saludos.
                      Kernel Source Blog sobre Software Libre Desde mi azotea - Mi blog de astronomía ............
        • Re: Solicito ayuda para sonido y teléfono

          Escrito por ailime el 27/04/2006 09:34

          ailime

          Iniciado Ancestral

          Envíos: 80

          Mira y busca la linea q te ponga algo sobre AUDIO CONTROLLER o
          sound controller y hay veras los datos de tu tarjeta de sonido,pero vamos si no te quedas conforme mandame la salida del coamando y ya te comento
          ;-)
          • Re: Solicito ayuda para sonido y teléfono

            Escrito por soberon el 28/04/2006 05:44

            soberon

            Adepto Ancestral

            Envíos: 299

            Hola Ailime (Emilia?...). Gracias por tu apoyo.
            Bueno, el comando lspci arroja solo 3 cosas:
            Host Bridge: Toshiba... etc.
            VGA compatible controller Chips and Technologies F65554
            USB Controller NEC Corp...
            Y nada de "audio" o "sound"; deduzco que el sistema no "lo ve".
            ¿Hay algo que se pueda hacer con esto???
            Gracias de antemano y saludos
            :-D
            ...
            • Re: Solicito ayuda para sonido y teléfono

              Escrito por ailime el 02/05/2006 08:51

              ailime

              Iniciado Ancestral

              Envíos: 80

              Soberon observa este SITIO q parece dar algunos datos interesantes sobre los portatiles toshiba , a ver si solucionas algo. Sino es asi. Avisalo y seguiremos buscando
              ;-)
              • Re: Solicito ayuda para sonido y teléfono

                Escrito por soberon el 03/05/2006 02:38

                soberon

                Adepto Ancestral

                Envíos: 299

                Hola de nuevo Basoalto y Ailime...
                Pues ya estuve explorando "la matriz" (estilo W. Gibson) y aparentemente encontré una respuesta ¡pero no la entiendo al 100%!... Por eso sigo "enchinchándolos" y abusando de su paciencia para con los novatos como yo.
                Ya en el lejano 2000, dos personas dan una receta para mi equipo (Toshiba Satellite 220) con la tarjeta Yamaha; las adhiero enseguida:
                Esa es la tarjeta de sonido que poseo y me gustaria que sonara en mi
                > potato.
                >
                > Estos son sus parametros, segun windows:
                >
                > dma: 00,01
                > irq:05
                > I/O:0220-0225F
                > 0530-0537
                > 0388-038B
                > 0330-0331
                > 0370-0371
                > Que debo de hacer para que suene?

                Yo la incluí en el núcleo y ningún problema. (Tengo un Toshiba 220 que
                tiene estos chips de sonido integrados en la placa)

                Te incluyo la parte de la configuración del kernel que tiene que ver con
                sonido.

                Saludos,

                #
                # Sound
                #
                CONFIG_SOUND=y
                # CONFIG_SOUND_CS4281 is not set
                # CONFIG_SOUND_FUSION is not set
                # CONFIG_SOUND_EMU10K1 is not set
                # CONFIG_SOUND_ES1370 is not set
                # CONFIG_SOUND_ES1371 is not set
                # CONFIG_SOUND_MAESTRO is not set
                # CONFIG_SOUND_ICH is not set
                # CONFIG_SOUND_SONICVIBES is not set
                # CONFIG_SOUND_TRIDENT is not set
                # CONFIG_SOUND_MSNDCLAS is not set
                # CONFIG_SOUND_MSNDPIN is not set
                CONFIG_SOUND_OSS=y
                # CONFIG_SOUND_DMAP is not set
                # CONFIG_SOUND_PAS is not set
                CONFIG_SOUND_SB=y
                CONFIG_SB_BASE=220
                CONFIG_SB_IRQ=5
                CONFIG_SB_DMA=0
                CONFIG_SB_DMA2=5
                CONFIG_SB_MPU_BASE=330

                #
                # MPU401 IRQ is only required with Jazz16, SM Wave and ESS1688.
                #

                #
                # Enter -1 to the following question if you have something else such as SB16/32.
                #
                CONFIG_SB_MPU_IRQ=-1
                # CONFIG_SOUND_GUS is not set
                # CONFIG_SOUND_MPU401 is not set
                # CONFIG_SOUND_PSS is not set
                # CONFIG_SOUND_MSS is not set
                # CONFIG_SOUND_SSCAPE is not set
                # CONFIG_SOUND_TRIX is not set
                # CONFIG_SOUND_VIA82CXXX is not set
                # CONFIG_SOUND_MAD16 is not set
                # CONFIG_SOUND_WAVEFRONT is not set
                # CONFIG_SOUND_CS4232 is not set
                # CONFIG_SOUND_OPL3SA2 is not set
                # CONFIG_SOUND_MAUI is not set
                # CONFIG_SOUND_SGALAXY is not set
                CONFIG_SOUND_OPL3SA1=m
                # CONFIG_SOUND_SOFTOSS is not set
                CONFIG_SOUND_YM3812=m
                # CONFIG_SOUND_VMIDI is not set
                # CONFIG_SOUND_UART6850 is not set
                # CONFIG_SOUND_NM256 is not set
                # CONFIG_SOUND_YMPCI is not set

                -----------------------------------------------------------------------------------------------------------
                Segunda respuesta:

                .config del nucleo:

                # Sound
                #
                CONFIG_SOUND=y
                # CONFIG_SOUND_CMPCI is not set
                # CONFIG_SOUND_EMU10K1 is not set
                # CONFIG_SOUND_ES1370 is not set
                # CONFIG_SOUND_ES1371 is not set
                # CONFIG_SOUND_ESSSOLO1 is not set
                # CONFIG_SOUND_MAESTRO is not set
                # CONFIG_SOUND_SONICVIBES is not set
                # CONFIG_SOUND_TRIDENT is not set
                # CONFIG_SOUND_MSNDCLAS is not set
                # CONFIG_SOUND_MSNDPIN is not set
                # CONFIG_SOUND_VIA82CXXX is not set
                CONFIG_SOUND_OSS=y
                CONFIG_SOUND_TRACEINIT=y
                CONFIG_SOUND_DMAP=y
                # CONFIG_SOUND_AD1816 is not set
                # CONFIG_SOUND_SGALAXY is not set
                # CONFIG_SOUND_ADLIB is not set
                # CONFIG_SOUND_ACI_MIXER is not set
                # CONFIG_SOUND_CS4232 is not set
                # CONFIG_SOUND_SSCAPE is not set
                # CONFIG_SOUND_GUS is not set
                # CONFIG_SOUND_ICH is not set
                # CONFIG_SOUND_VMIDI is not set
                # CONFIG_SOUND_TRIX is not set
                # CONFIG_SOUND_MSS is not set
                CONFIG_SOUND_MPU401=m
                # CONFIG_SOUND_NM256 is not set
                # CONFIG_SOUND_MAD16 is not set
                # CONFIG_SOUND_PAS is not set
                # CONFIG_PAS_JOYSTICK is not set
                # CONFIG_SOUND_PSS is not set
                CONFIG_SOUND_SOFTOSS=m
                # CONFIG_SOUND_SB is not set
                # CONFIG_SOUND_AWE32_SYNTH is not set
                # CONFIG_SOUND_WAVEFRONT is not set
                # CONFIG_SOUND_MAUI is not set
                CONFIG_SOUND_YM3812=m
                CONFIG_SOUND_OPL3SA1=m
                CONFIG_SOUND_OPL3SA2=m
                # CONFIG_SOUND_YMPCI is not set
                CONFIG_SOUND_UART6850=m
                # CONFIG_SOUND_AEDSP16 is not set
                # CONFIG_SOUND_TVMIXER is not set


                Y para cargar los modulos lo hago a pelo:

                indmod mpu401
                insmod ad1848
                insmod opl3sa2 io=0x370 mss_io=0x530 mpu_io=0x330 irq=9 dma=1 dma2=3
                insmod opl3 io=0x388

                ENTONCES...
                Mis dudas son: ¿cuál receta sigo? y... ¿serían tan gentiles de esclarecer COMO seguirlas?... es decir, para un "analfabeta funcional como yo ¿que hago?... ¿me pongo en consola como "root"? ¿luego que comando escribo? ¿a que directorio me paso? etc.
                Si tienen la paciencia y el tiempo de auxiliarme les quedaré muy agradecido.
                Reciban un afectuoso saludo desde México :-D
                ...
    • Re: Solicito ayuda para sonido y teléfono

      Escrito por soberon el 14/05/2006 19:06

      soberon

      Adepto Ancestral

      Envíos: 299

      Saludos Basoalto y Ailime...
      ¿Tiene remedio mi caso?... ¡claro! que no sea tirar el equipo o ignorar el sonido :lol:
      Gracias y hasta pronto
      ...
      • Re: Solicito ayuda para sonido y teléfono

        Escrito por ailime el 23/05/2006 09:06

        ailime

        Iniciado Ancestral

        Envíos: 80

        Soberon la verdad q ya no se que mas decirte, ya me has pillado. Tu pregunta me ha tenido buscando informacion bastante tiempo pero no he encontrado nada aceptable y que pueda solucionar tu problema. Abre otro hilo nuevo a ver si hay mas gente q te pueda ayudar.
        Siento el no poder ayudarte mas, pero como tampoco tengo un modelo asi para ir probando y bicheando.
        ;-)
        • Re: Solicito ayuda para sonido y teléfono

          Escrito por soberon el 23/05/2006 16:26

          soberon

          Adepto Ancestral

          Envíos: 299

          ¡Que Vaaa!...
          En verdad agradezco mucho el esfuerzo y tiempo que inviertes en un desconocido.
          Con los consejos que me dieron y mis propias chapuzas, creo que la cosa va en meter el módulo de la Yamaha (olp3sa2) en el ALSA que trae la Mini... ¡claro que esto resulta un galimatías para mi!, pero eso puede funcionar.
          Si me pueden ayudar o guiar con esto, se los agradeceré mucho.
          Gracias de nuevo y que la pasen de fábula
          :-D :-) :-P
          ...
Buscador
Menú
Los que más escribieron en el último año
1

indiocabreao

80
2

miancatri

51
3

hatteras

45
4

vendrell

36
5

guabyboy

29
6

javarulo

20
7

daniel2503

19
8

cpcero

16
9

dlobatod

14
10

seneka77

11
11

mouronte

8
12

jcamdom

8
13

crash28

7
14

alemoreno

6
15

ghasthelm

6
16

guliex

6
 

Hecho con Plone CMS, el Sistema de Gestión de Contenidos de Fuentes Abiertos

Este sitio cumple con los siguientes estándares: