Herramientas Personales
Usted está aquí: Inicio ¡Participa! Foros
Acciones de Documento
Hilo abierto

SOLUCIONADO EL TEMA: SOCORRO Solucion actualizar

Volver al foro (Usando Guadalinex V7)
Orden:   
  • Escrito por aceca el 06/08/2010 19:17

    aceca

    Adepto Ancestral

    Envíos: 109

    Cuando le di a que se me actualizara algunas cosas que me salieron para actualizar no se termino bien  o no se que le ocurre a no se que de dependencias pues me salieron 3 errores de instalación:

    1 era por rhythmbox,

    2 totem

    3 nautilus

    Cuando le doy a comando apt en la terminal me sale esto para todo, (solo pongo el del rhythmbox)

    "sudo apt-get --reinstall install rhytmbox
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias      
    Leyendo la información de estado... Hecho
    E: El paquete rhythmbox necesita ser reinstalado, pero no se encuentra un archivo para éste."

    Y cuando abro synaptic me sale esto:

    "E: El paquete rhythmbox necesita ser reinstalado, pero no se encuentra un archivo para éste.

    E: Error interno al abrir el caché (1)."

     

    E: /var/cache/apt/archives/nautilus-data_1%3a2.30.1-0ubuntu1.1_all.deb: el subproceso script post-removal nuevo devolvió el código de salida de error 1

    E: /var/cache/apt/archives/rhythmbox_0.12.8-0ubuntu7_i386.deb: el subproceso script post-removal nuevo devolvió el código de salida de error 1

    E: /var/cache/apt/archives/totem-common_2.30.0git20100413-0ubuntu1_all.deb: el subproceso script post-removal nuevo devolvió el código de salida de error 1

     

    Un saludo a ver si me lo solucionais porfa

    • Re: SOCORRO Solucion actualizar

      Escrito por cmuinos el 13/08/2010 00:53

      cmuinos

      Visitante Ancestral

      Envíos: 1

      a mi me ocurre exactamente lo mismo y he enviado una consulta al soporte técnico, aunque todavía no tengo respueta

    • Re: SOCORRO Solucion actualizar

      Escrito por s.tecnico.dav el 13/08/2010 09:13

      s.tecnico.dav

      Equipo Guadalinex

      Envíos: 37

      Tienes los sources.list originales de Guadalienx v7, si los has modificado y añadido repositorios distintos (por ejemplo los de Ubuntu) es probable que cree inconsistencia de paquetes.

    • Re: SOCORRO Solucion actualizar

      Escrito por josemiguel1974 el 13/08/2010 23:06

      josemiguel1974

      Iniciado Ancestral

      Envíos: 49

      Hola, me ocurre algo diferente y sin embargo creo que parecido, ya que me da la sensación que el origen es el mismo. Me gusta personalizar la imagen squashfs quitando y poniendo cosas a mi gusto, así que cuando entro a chroot y hago "aptitude purge ~o" que purga los paquetes obsoletos me ocurre un desastre cuando intenta resolver todo y quita y pone kernels, headers y cosas muy básicas y aceptando las soluciones que propone, sólo consigo que el DVD no sirva pa ná. Si alguien tiene alguna idea, soy todo oídos, el log es el siguiente:

       

      root@usuario-desktop:~# chroot /root/editsquashfs
      root@usuario-desktop:/# mount -t proc none /proc
      root@usuario-desktop:/# mount -t sysfs none /sys
      root@usuario-desktop:/# mount devpts /dev/pts -t devpts
      root@usuario-desktop:/# aptitude purge ~o
      Leyendo lista de paquetes... Hecho
      Creando árbol de dependencias      
      Leyendo la información de estado... Hecho
      Leyendo la información de estado extendido     
      Inicializando el estado de los paquetes... Hecho
      Los siguientes paquetes están ROTOS:
        linux-headers-generic linux-image-generic
      Se ELIMINARÁN los siguientes paquetes:
        linux-headers-2.6.32-22{p} linux-headers-2.6.32-22-generic{p} linux-image-2.6.32-22-generic{p}
      0 paquetes actualizados, 0 nuevos instalados, 3 para eliminar y 0 sin actualizar.
      Necesito descargar 0B de ficheros. Después de desempaquetar se liberarán 182MB.
      No se satisfacen las dependencias de los siguientes paquetes:
        linux-headers-generic: Depende: linux-headers-2.6.32-22-generic pero no es instalable
        linux-image-generic: Depende: linux-image-2.6.32-22-generic pero no es instalable
      Las acciones siguientes resolverán estas dependencias

      Eliminar los paquetes siguientes:
      linux-generic

      Instalar los paquetes siguientes:
      linux-headers-2.6.32-21 [2.6.32-21.32 (lucid)]
      linux-headers-2.6.32-21-generic [2.6.32-21.32 (lucid)]
      linux-image-2.6.32-21-generic [2.6.32-21.32 (lucid)]

      Desactualizar los paquetes siguientes:
      linux-headers-generic [2.6.32.22.23 (now) -> 2.6.32.21.22 (lucid)]
      linux-image-generic [2.6.32.22.23 (now) -> 2.6.32.21.22 (lucid)]

      La puntuación es 152

      ¿Acepta esta solución? [Y/n/q/?] y
      Se DESACTUALIZARÁN los siguientes paquetes:
        linux-headers-generic linux-image-generic
      Se instalarán los siguiente paquetes NUEVOS:
        linux-headers-2.6.32-21{a} linux-headers-2.6.32-21-generic{a} linux-image-2.6.32-21-generic{a}
      Se ELIMINARÁN los siguientes paquetes:
        linux-generic{a} linux-headers-2.6.32-22{p} linux-headers-2.6.32-22-generic{p} linux-image-2.6.32-22-generic{p}
      0 paquetes actualizados, 3 nuevos instalados, 2 desactualizados, 4 para eliminar y 0 sin actualizar.
      Necesito descargar 41,5MB de ficheros. Después de desempaquetar se liberarán 53,2kB.
      ¿Quiere continuar? [Y/n/?] y
      Escribiendo información de estado extendido... Hecho
      Des:1 http://v7.guadalinex.org/ubuntu/ lucid/main linux-headers-2.6.32-21 2.6.32-21.32 [9865kB]
      Des:2 http://v7.guadalinex.org/ubuntu/ lucid/main linux-headers-2.6.32-21-generic 2.6.32-21.32 [728kB]                                                                          
      Des:3 http://v7.guadalinex.org/ubuntu/ lucid/main linux-headers-generic 2.6.32.21.22 [3916B]                                                                                    
      Des:4 http://v7.guadalinex.org/ubuntu/ lucid/main linux-image-2.6.32-21-generic 2.6.32-21.32 [30,9MB]                                                                           
      Des:5 http://v7.guadalinex.org/ubuntu/ lucid/main linux-image-generic 2.6.32.21.22 [3928B]                                                                                      
      Descargados 41,5MB en 59s (697kB/s).                                                                                                                                            
      (Leyendo la base de datos ...  00%
      155388 ficheros y directorios instalados actualmente.)
      Desinstalando linux-generic ...
      Seleccionando el paquete linux-headers-2.6.32-21 previamente no seleccionado.
      (Leyendo la base de datos ...  00%
      155386 ficheros y directorios instalados actualmente.)
      Desempaquetando linux-headers-2.6.32-21 (de .../linux-headers-2.6.32-21_2.6.32-21.32_all.deb) ...
      Seleccionando el paquete linux-headers-2.6.32-21-generic previamente no seleccionado.
      Desempaquetando linux-headers-2.6.32-21-generic (de .../linux-headers-2.6.32-21-generic_2.6.32-21.32_i386.deb) ...
      dpkg: aviso: revirtiendo linux-headers-generic de 2.6.32.22.23 a 2.6.32.21.22
      Preparando para reemplazar linux-headers-generic 2.6.32.22.23 (usando .../linux-headers-generic_2.6.32.21.22_i386.deb) ...
      Desempaquetando el reemplazo de linux-headers-generic ...
      (Leyendo la base de datos ...  00%
      173793 ficheros y directorios instalados actualmente.)
      Desinstalando linux-headers-2.6.32-22-generic ...
      dpkg: linux-headers-2.6.32-22: problemas de dependencias, pero se desinstalará de todas formas
       tal y como se solicitó:
       bcmwl-kernel-source depende de linux-headers-generic | linux-headers; sin embargo:
       El paquete `linux-headers-generic' no está configurado todavía.
        El paquete `linux-headers' no está instalado.
        El paquete `linux-headers-2.6.32-22' provee `linux-headers' pero va a ser desinstalado.
        El paquete `linux-headers-2.6.32-21' que provee `linux-headers' aún no está configurado.
        El paquete `linux-headers-2.6.32-21-generic' que provee `linux-headers' aún no está configurado.
        El paquete `linux-headers-2.6.32-22-generic' que provee linux-headers no está instalado.
      Desinstalando linux-headers-2.6.32-22 ...
      Seleccionando el paquete linux-image-2.6.32-21-generic previamente no seleccionado.
      (Leyendo la base de datos ...  00%
      155387 ficheros y directorios instalados actualmente.)
      Desempaquetando linux-image-2.6.32-21-generic (de .../linux-image-2.6.32-21-generic_2.6.32-21.32_i386.deb) ...
      Done.
      dpkg: aviso: revirtiendo linux-image-generic de 2.6.32.22.23 a 2.6.32.21.22
      Preparando para reemplazar linux-image-generic 2.6.32.22.23 (usando .../linux-image-generic_2.6.32.21.22_i386.deb) ...
      Desempaquetando el reemplazo de linux-image-generic ...
      (Leyendo la base de datos ...  00%
      158770 ficheros y directorios instalados actualmente.)
      Desinstalando linux-image-2.6.32-22-generic ...
      Examining /etc/kernel/prerm.d.
      run-parts: executing /etc/kernel/prerm.d/dkms 2.6.32-22-generic /boot/vmlinuz-2.6.32-22-generic
      Uninstalling: bcmwl 5.60.48.36+bdcom (2.6.32-22-generic) (i686)

      -------- Uninstall Beginning --------
      Module:  bcmwl
      Version: 5.60.48.36+bdcom
      Kernel:  2.6.32-22-generic (i686)
      -------------------------------------

      Status: Before uninstall, this module version was ACTIVE on this kernel.

      wl.ko:
       - Uninstallation
         - Deleting from: /lib/modules/2.6.32-22-generic/updates/dkms/
       - Original module
         - No original module was found for this module on this kernel.
         - Use the dkms install command to reinstall any previous module version.
      depmod......

      DKMS: uninstall Completed.
      The link /vmlinuz is a damaged link
      Removing symbolic link vmlinuz
       you may need to re-run your boot loader[grub]
      The link /initrd.img is a damaged link
      Removing symbolic link initrd.img
       you may need to re-run your boot loader[grub]
      Purgando ficheros de configuración de linux-image-2.6.32-22-generic ...
      Configurando linux-headers-2.6.32-21 (2.6.32-21.32) ...
      Configurando linux-headers-2.6.32-21-generic (2.6.32-21.32) ...
      Examining /etc/kernel/header_postinst.d.
      run-parts: executing /etc/kernel/header_postinst.d/dkms 2.6.32-21-generic /boot/vmlinuz-2.6.32-21-generic
      run-parts: executing /etc/kernel/header_postinst.d/nvidia-common 2.6.32-21-generic /boot/vmlinuz-2.6.32-21-generic

      Configurando linux-headers-generic (2.6.32.21.22) ...
      Configurando linux-image-2.6.32-21-generic (2.6.32-21.32) ...
      Running depmod.
      update-initramfs: Generating /boot/initrd.img-2.6.32-21-generic
      cryptsetup: WARNING: could not determine root device from /etc/fstab
      .: 6: Can't open /scripts/casper-functions
      .: 6: Can't open /scripts/casper-functions
      .: 6: Can't open /scripts/casper-functions
      .: 6: Can't open /scripts/casper-functions
      .: 6: Can't open /scripts/casper-functions
      Examining /etc/kernel/postinst.d.
      run-parts: executing /etc/kernel/postinst.d/dkms 2.6.32-21-generic /boot/vmlinuz-2.6.32-21-generic
      run-parts: executing /etc/kernel/postinst.d/nvidia-common 2.6.32-21-generic /boot/vmlinuz-2.6.32-21-generic
      run-parts: executing /etc/kernel/postinst.d/pm-utils 2.6.32-21-generic /boot/vmlinuz-2.6.32-21-generic

      Configurando linux-image-generic (2.6.32.21.22) ...
      Leyendo lista de paquetes... Hecho                  
      Creando árbol de dependencias      
      Leyendo la información de estado... Hecho
      Leyendo la información de estado extendido      
      Inicializando el estado de los paquetes... Hecho
      Escribiendo información de estado extendido... Hecho

      Estado actual: 23 nuevos [-3].

    • Re: SOCORRO Solucion actualizar

      Escrito por majesan7 el 17/08/2010 22:21

      majesan7

      Usuario Ancestral

      Envíos: 9

      Puedes mirar en synaptic si tienes algún paquete roto, o busca allí los paquetes que te dan errores y puedes marcar para reinstalar, o también instalar de nuevo.

      En caso de que tengas paquetes rotos tienes que desinstalarlos

      luego instalas los otros.

      Otra cosa puede ser que se haya apagado antes de actualizar los paquetes en ese caso

      sudo apt-get update

    • Re: SOCORRO Solucion actualizar

      Escrito por majesan7 el 17/08/2010 22:22

      majesan7

      Usuario Ancestral

      Envíos: 9

      Puedes mirar en synaptic si tienes algún paquete roto, o busca allí los paquetes que te dan errores y puedes marcar para reinstalar, o también instalar de nuevo.

      En caso de que tengas paquetes rotos tienes que desinstalarlos

      luego instalas los otros.

      Otra cosa puede ser que se haya apagado antes de actualizar los paquetes en ese caso

      sudo apt-get update

    • Re: SOCORRO Solucion actualizar

      Escrito por Tocinete el 18/08/2010 20:30

      Tocinete

      Iniciado Ancestral

      Envíos: 93

      Hola,

      a mi también me ha pasado lo mismo después de actualizar me aparece un mensaje de error con los paquetes de nautilus y rhythmbox.

      Las fuentes que tengo son estas:

      #TITLE: Sitio principal de Guadalinex en la Junta de Andalucia
      #ID:jda

      deb http://v7.guadalinex.org/ubuntu lucid main restricted universe multiverse
      deb http://v7.guadalinex.org/guadalinex-lince lince main restricted universe multiverse
      deb http://v7.guadalinex.org/guadalinex-lince lince-updates main restricted universe multiverse
      deb http://v7.guadalinex.org/guadalinex-lince lince-security main restricted universe multiverse
      deb http://v7.guadalinex.org/guadalinex-lince lince-backports main restricted universe multiverse
      #END

      Por lo menos creo que coincide con el repositorio http://pool.guadalinex.org/app/

      Por cierto la página de inicio de Firefox también se modifica, se puede solucionar file:///usr/share/guadalinex-about/index.html

      Saludos,

      ......
      • Re: SOCORRO Solucion actualizar

        Escrito por elmoj el 19/08/2010 01:48

        elmoj

        Visitante Ancestral

        Envíos: 1

        Otro que se apunta al carro!!

         

        Instalación limpia, darle al botón de actualizar y ala! problemas al canto...

         

        Lo único que he podido hacer es reinstalar y prohibir actualizar :(

         

        He abierto un ticket y si encuentro la solución la pongo.

         

        Saludos!

      • Re: SOCORRO Solucion actualizar

        Escrito por s.tecnico.apb el 19/08/2010 08:19

        s.tecnico.apb

        Equipo Guadalinex

        Envíos: 248

        Estimado usuario, estamos comprobando el fallo que existe con dichos paquetes.

        En breve se publicará la solución al problema.

        Un saludo!

        • Re: SOCORRO Solucion actualizar

          Escrito por GaMo65 el 19/08/2010 13:35

          GaMo65

          Visitante Ancestral

          Envíos: 1

          Hola, acabo de registrarme y es la pimera vez que accedo al foro. Es interesante y creo que se puede aprender mucho y si es posible echar una mano.

           

          Yo he tenido el mismo problema y como soy novato en linux he decidido reistalarlo por completo con la ISO.

          Aún no me he conectado a internet y la pregunta es si debo hacer una actualización de todos los programas, esperar a que salga la solución o no actualizar los dos paquetes que dan el error.

          ¡No sé que hacer! Si alguien me puede aportar algo se lo agradecería.

           

          • Re: SOCORRO Solucion actualizar

            Escrito por s.tecnico.apb el 19/08/2010 19:46

            s.tecnico.apb

            Equipo Guadalinex

            Envíos: 248

            Estimado usuario, ya se puede actualizar el sistema. Si no se ha realizado ninguna actualización hasta hoy, desde el gestor de actualizaciones [Sistema -> Administración -> Gestor de actualizaciones] se puede actualizar.

            Para ello instalar las actualizaciones que aparecen o bien sólo instalar la actualización del paquete guadalinex-desktop-conf, una vez hecho esto (el proceso se llevará un rato en el primer caso) el sistema indicará que ha habido un error y quedan pendientes dos actualizaciones.

            Repetir el proceso de instalar las actualizaciones restantes y estas se instalarán ya que el error surge porque el paquete arriba indicado debería instalarse antes que el paquete nautilus-data entonces en la segunda actualización ya se encuentra actualizado y se terminarán de instalar.

            Continuamos estudiando el problema para que no sea necesario repetir el proceso dos veces.

             

            Si algún usuario continúa teniendo algún problema puede ponerse en contacto con el equipo de soporte para ayudarle en solucionar el problema.

            http://www.guadalinex.org/ayuda/formulario-de-soporte

             

            Un saludo!

             

             

            • Re: SOCORRO Solucion actualizar

              Escrito por Tocinete el 19/08/2010 22:54

              Tocinete

              Iniciado Ancestral

              Envíos: 93

              Hola,

              desde el gestor de actualizaciones no me funciona, pero si se hace desde el gestor de paquetes si.

              Una curiosidad, por que tiene dependencia el paquete myspell-en-za (Ingles sudafricano para OpenOffice) con los paquetes de Guadalinex?

              saludos,

              ......
    • Re: SOCORRO Solucion actualizar

      Escrito por aceca el 24/08/2010 17:22

      aceca

      Adepto Ancestral

      Envíos: 109

      hay que actualizar primero "el paquete guadalinex-desktop-conf" asi que lo busco en el synaptic y me aparecen dos: pero actualize a la version mas nueva y vuala se soluciono el de problema actualizándolo todo y sin errores

      esta es la version que lo arregla

      guadalinex-desktop-conf version  v7r5399

Buscador
Menú
Los que más escribieron en el último año
1

seneka77

15
2

indiocabreao

6
3

miancatri

4
4

jacobcors

4
5

lukenlow

4
6

sseneca101

3
7

damianosullivan

3
8

eulogos

3
9

transistor47

2
10

azamrod

2
11

saeed

2
12

josepanadero

2
13

bank0000cb

1
14

daniel25

1
15

evaaa

1
16

daniel1975

1
 

Hecho con Plone CMS, el Sistema de Gestión de Contenidos de Fuentes Abiertos

Este sitio cumple con los siguientes estándares: